Forums Abandonware

Lankhor.net - Abw-Definition - Abw-Magazines - Abw-Videos - Abw annuaire
Nous sommes le 21-08-2017 18:26

Heures au format UTC+02:00




Poster un nouveau sujet  Répondre au sujet  [ 26 messages ]  Aller à la page 1 2 Suivante
Auteur Message
Message non luPosté : 26-10-2016 12:06 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
Bonjour,
je viens de racheter Warm Up et j'ai qqs soucis.
Mes PC sont sous Windows 10 64 bits et je lance le jeu en administrateur et en compatibilité Windows XP.
Une fois dans le jeu, je sélectionne "Arcade" puis "Départ".
La course se déroule normalement et près les 3 tours de circuits, le logiciel affiche "Niveau suivant" (je ne suis pas sûr des termes exacts)
puis l'écran devient noir et une fenêtre d'erreur apparait : Pôle position 2001 a cessé de fonctionner
J'ai essayé (sans trop y croire) une réparation avec Windows mais j'ai toujours le même défaut.
J'ai également fait un essai avec un second PC mais résultat identique.
Si quelqu'un a une idée pour résoudre mon problème, merci.
Bonne journée
Astarté


Haut
   
Message non luPosté : 26-10-2016 16:26 
Hors ligne
Legendary

Enregistré le : 22-02-2012 08:00
Messages : 393
Salut,

En effet, le problème ne semble pas venir du programme lui même, mais de Windows.

De nombreux programmes sous win32, ont des problèmes d'accès disque.
Le problème se pose lors d'un appelé récurant de fichiers de sauvegarde sur le disque dur!
Résultat, sur les émulateurs, le chargement de la rom ne s'effectue qu'au démarrage et plante en cas de reset.
Dans ton cas, le programme fait appel à la disquette ou aux ressources du jeux... qui se trouve bloquées par Windows, car il estime que le programme une fois chargé dans Windows n'a plus besoin d'infos!
Le problème vient soit de ton antivirus, soit du système de "ROAMMING" de Windows, qui s'emmêle les pinceaux.
Pour éviter le déplacement de fichiers en RAOMMING, il faut à tout prix éviter des installations manuelles dans le répertoire "Program files" ou "Programmes", et privilégier des répertoires hors des zones protégées de Windows.
Tu dois créer un répertoire "c:\jeux" puis y mettre ton fichier exécutable.
Sinon, tu te retrouvera avec des fichiers fantômes en 'roamming', ayant un écho dans plusieurs répertoires.

Dans le nom de répertoire, il faut éviter les "éàç"... et les noms trop long.
Je parle ici des fichiers de sauvegarde émulateurs (DSK,ROM,CAS,TZX...) et parfois, les émulateurs eux même, qui font appelle à tous ces fichiers.
Donc, déplacement du programme dans un répertoire au nom simple, sous la racine "C:", "D:"...

Pour l'Antivirus, il peut aussi avoir un problème de latence de scrutation... le programme est scanné trop longtemps (...pour un code non compatible avec les Windows récents), et le fichier et impossible à lire, car l'antivirus le bloque!

Donc, il faut paramétrer l'antivirus pour qu'il mette en mémoire le résultat des scans... car à la seconde tentative, l'antivirus ne le scannera pas... et donnera la mains au logiciel plus rapidement!
Généralement, une option est prévue dans l'antivirus.

Autre solution, utiliser un émulateur comme "DosBox" (si programme DOS), qui exécutera le programme sous un environnement plus lent, et plus maîtrisé au niveau des accès disque.

Cela sera de tout façon impératif d'utiliser ce genres d'outils pour les anciens programmes (DOS/W32), et ainsi utiliser des émulateurs sous un autre émulateur!
Les problèmes de compatibilités sont de plus en plus courant avec les nouvelles machines, et de nombreux programme ne supportent plus ces machines trop rapide et trop récentes.

Amuse toi bien.
;-)


Haut
   
Message non luPosté : 26-10-2016 16:39 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
Bonjour Xavier et merci pour ta réponse,
le programme a été installé dès le départ en f:/Jeux/Warm up.
Je vais également faire un essai en désactivant l'antivirus BitDefender
J'avais pensé à un problème de DirectX.
Windows 10 est à la 12 et le programme installe la version 9


Haut
   
Message non luPosté : 26-10-2016 17:49 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
J'ai désactivé l'antivirus de BD et le programme se plante toujours au même endroit.


Haut
   
Message non luPosté : 26-10-2016 22:00 
Hors ligne
Legendary

Enregistré le : 22-02-2012 08:00
Messages : 393
Salut,

Oui, DirectX peut poser problème...
Plus d'infos ici : http://cpcrulez.fr/forum/viewtopic.php?f=7&t=5808

C'est pour un émulateur, mais tu as des liens sur la mise à jour de DirectX, car les anciens jeux écrasent maladroitement les versions les plus récentes.
Fait les vérifications indiquées, puis mets le DirectX récent à jour.
Bonne lecture!


Haut
   
Message non luPosté : 27-10-2016 17:11 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
Bonjour, j'ai réinstallé DirectX mais c'est toujours pareil.
J'ai recherché dans les journaux d'évènements pour savoir si une erreur avait été détectée mais je n'ai rien trouvé.
Le problème est que je n'ai aucune indication sur la nature du problème (fichier manquant, conflit, ...)


Haut
   
Message non luPosté : 27-10-2016 19:13 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
Je commence un peu à douter de la responsabilité de DirectX. Les graphismes sont corrects et le jeu ne se plante jamais pendant une course.
C'est seulement en cas de changement de niveau ou d'abandon.


Haut
   
Message non luPosté : 28-10-2016 01:29 
Hors ligne
Legendary

Enregistré le : 22-02-2012 08:00
Messages : 393
Citation :
Pôle position 2001 a cessé de fonctionner

Zut chez moi aussi, quand j'ai ce message, pas de détails...

Et en "mode sans échec", F8 au démarrage... Tu as aussi un plantage?
Car parfois, ça arrive en mettant deux programmes DirectX en fonctionnement en même temps!
L'émulateur "Eighty-one" avec d'autres... en VisualBasic... ou autres.
Tu dois avoir un résident qui fait aussi appel à DX!
Et ça le Windows, il n'aime pas trop...
:shock:


Haut
   
Message non luPosté : 28-10-2016 11:45 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
Bonjour Xavier,
j'ai essayé le mode sans échec mais sans pouvoir lancer le jeu.
Avec un compte admin, j'ai le message d'erreur suivant : "Impossible d'ouvrir cette application (1008). Impossible d'ouvrir "Prise en main" à l'aide du compte administrateur intégré. Connectez-vous à l'aide d'un autre compte et réessayez".
Je pensais avoir désactiver l'UAC et que le problème venait de là mais dans le registre enableLUA est bien à 1.

J'ai essayé ensuite avec un compte utilisateur toujours en sans échec mais là je tombe sur des messages de Tages.drivers :
The drivers require installation (with an administrator's account)
Puis quand je rentre le mot de passe du compte admin, j'ai de nouveau un message de Tages.drivers :
Unable to proceed (error 1084)

Bonne journée et bon week-end


Haut
   
Message non luPosté : 28-10-2016 13:40 
Hors ligne
Legendary

Enregistré le : 22-02-2012 08:00
Messages : 393
Salut Astarté,
Arf ! Tout devient compliqué avec ces "nouveaux" Windows...
Une installation sur une clef USB?
(Je n'y crois plus vraiment!)
:?
C'est du vrai directX ou de l'OpenGL émulé?
essaie de voir dans le panneau de config de la carte graphique!
cfg du jeu graphique basse résolution, sans son, sans triple-buffering...
:shock:


Haut
   
Message non luPosté : 28-10-2016 14:36 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
Je viens de voir une info qui m'avait échappé dans les journaux (applications)
Il y a bien un message d'erreur :

Nom de l’application défaillante WARM_UP_!.exe, version : 1999.5.20.0, horodatage : 0x3b29063d
Nom du module défaillant : DDRAW.dll, version : 10.0.14393.0, horodatage : 0x5789902a
Code d’exception : 0xc0000005
Décalage d’erreur : 0x00039e84
ID du processus défaillant : 0x1e4c
Heure de début de l’application défaillante : 0x01d23113611c4013
Chemin d’accès de l’application défaillante : F:\Jeux\WarmUp\WARM_UP_!.exe
Chemin d’accès du module défaillant: C:\Windows\SYSTEM32\DDRAW.dll
ID de rapport : ae4805a6-d872-4f2a-902d-e96684432b51
Nom complet du package défaillant :
ID de l’application relative au package défaillant :


Il semblerait que le défaut vienne de DDRAW.dll


Haut
   
Message non luPosté : 28-10-2016 14:59 
Hors ligne
Legendary

Enregistré le : 22-02-2012 08:00
Messages : 393
Et que dit "dxdiag.exe" ?


Haut
   
Message non luPosté : 28-10-2016 15:17 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
J'y étais allé mais je n'avais rien vu de spécial.
La version est la 12 et sur chaque onglet il est indiqué : aucun problème détecté


Haut
   
Message non luPosté : 28-10-2016 19:18 
Hors ligne
Legendary

Enregistré le : 22-02-2012 08:00
Messages : 393
Regarde quand même si il existe plusieurs version de cette DLL.

Parfois, les DLLs étaient placées dans le répertoire de l'exécutable.

Donc, dans ce cas, la version est trop ancienne.
Il suffit de le renommer, ou de l'effacer pour que la version "officielle" soit appelée dans les répertoires partagés de Windows.

La DLL du répertoire de l'exécutable est peut être prioritaire à la version réinstallée.


Haut
   
Message non luPosté : 28-10-2016 21:42 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
Ma version est la 10.0.14393.0 et date de juillet 2016.
Je ne pense pas qu'il y ait de versions ultérieures et cette dll n'est pas non plus dans les répertoire et sous-répertoires du jeu.


Haut
   
Message non luPosté : 29-10-2016 05:22 
Hors ligne
Legendary

Enregistré le : 22-02-2012 08:00
Messages : 393
Bhen...
C'est zut!!!
Tu vas être fort sur ce premier circuit... tu dois le connaitre par cœur.
:?
Bon, carte vidéo... mais les drivers sont plus récents que 2006!
Donc...
Désolé de ne pourvoir t'aider, sur ce problème de compatibilité DDraw.
Mais ça doit être un bug référencé, car ce jeu n'est pas si vieux...
Enfin, on n'est pas sur un jeu CGA!
As-tu un fichier ini dans le répertoire du jeu?
Généralement, des infos DX sont incluse... tu le copie, et tu modifies le driver si il est sur noté "drivers par défaut".

[edit] Pas gagné, c'est surement dans la base de registre!


Haut
   
Message non luPosté : 29-10-2016 10:16 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
Bonjour,
il n'y a pas de fichiers ini dans le répertoire.
Concernant le registre, je vois des appels vers DXsetup.exe qui se trouve dans le répertoire du jeu.
Mais je l'ai déjà lancé et sans résultat.
J'ai également un autre exécutable DXwebsetup.exe qui ne se trouve pas dans le répertoire du jeu
mais dans le répertoire de téléchargement du jeu.


Haut
   
Message non luPosté : 29-10-2016 10:43 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
Je vois dans les caractéristiques du jeu qu'il est prévu pour Windows 95, 98 ou 2000
J'ai encore un PC XP et un Vista mais l'OS est + récent.
De plus, j'ai acheté le jeu par téléchargement et il semblerait que le nombre
d'installations soit limité. enfin, c'est ce que Nexway indiquait


Haut
   
Message non luPosté : 29-10-2016 19:03 
Hors ligne
Legendary

Enregistré le : 22-02-2012 08:00
Messages : 393
:?
Donc, installation sur XP, mais, si la protection ne marche plus au bout de la première installation...
Il faut renvoyer le fichier téléchargé et récupérer un fichier d'installation qui fonctionne!
:shock:
C'est donc à voir avec le vendeur.
Demande quand même des explications à Nexway...

Plus sérieusement, il est toujours possible d'installer Dos-box avec une image de disque dur avec une partition W98/2000.
Avec un Dx d'époque préinstallé.
Essaie de copier les fichiers sur une clé USB, de lancer le setup DX sous XP...
Mais, si le programme est protégé, il te manquera des morceaux.

Tu peux aussi te procurer une Démo du jeu, de l'installer sous XP...
Puis réinstaller le jeu en lieu et place de la démo.
Car, le jeu est peut-être optimisé pour une version de directx disponible sur la démo... et non dans le kit d'installation!

Donc, regarder dans les Joystick, PC-team.... dans l'année de la sortie du jeu.


Haut
   
Message non luPosté : 30-10-2016 09:11 
Hors ligne
Blademaster

Enregistré le : 26-10-2016 11:53
Messages : 16
Bonjour,
je ne sais pas à combien d'installations j'ai droit.
Je vais contacter Nexway pour le savoir.
J'en suis déjà à 3. Deux sur le PC qui me sert à jouer et 1 sur un deuxième PC pour voir
si j'avais les mêmes erreurs.
Je vais essayer avec un PC XP en espérant un meilleur résultat.
Bon dimanche


Haut
   
Afficher les messages postés depuis :  Trier par  
Poster un nouveau sujet  Répondre au sujet  [ 26 messages ]  Aller à la page 1 2 Suivante

Heures au format UTC+02:00


Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas modifier vos messages
Vous ne pouvez pas supprimer vos messages
Vous ne pouvez pas joindre des fichiers

Rechercher :
Aller à :  
cron
Développé par phpBB® Forum Software © phpBB Limited
Traduit par phpBB-fr.com